X-lite DTMF Issue

This forum is for eyeBeam questions and support.

Moderator: Derek Jacobs

X-lite DTMF Issue

Postby oaaltone » Tue Nov 15, 2005 8:34 am

I cannot reliably send DTMF tones using the current X-lite build with AT&T CallVantage. I've tried both in-band and out-of-band, as well as increasing the DTMF tone length, to no avail. Whenever I have to enter touch tones (for example, to enter my voicemail password or a conference passcode), the system doesn't recognize my input. This has happened with a number of different phone systems I have placed calls to.

Any suggestions?
oaaltone
 
Posts: 1
Joined: Tue Nov 15, 2005 8:31 am

Postby wamatt » Tue Nov 15, 2005 11:50 pm

wonder how many posts its going to take before they admit there is a problem..
wamatt
 
Posts: 15
Joined: Mon Nov 07, 2005 10:33 am

Postby Derek Jacobs » Wed Nov 16, 2005 3:37 am

There is no DTMF issue.

Check your codec used, as well as your provider.
Derek Jacobs
Site Admin
 
Posts: 16898
Joined: Fri Mar 07, 2003 7:33 am
Location: Canton, Connecticut

Postby AlexB » Wed Nov 16, 2005 1:39 pm

Skibum wrote:There is no DTMF issue.

Check your codec used, as well as your provider.


I use Asterisk w/ chan_mISDN and have to send DTMF as RFC 2833 to pass them over the ISDN. The driver can translate only RFC 2833 tones into inband tones. This is the only configuration that can work and that we have always used here with SJphone.
Then we bought eyeBeam and installed it without making any change in the configuration. Tones can't be translated to inband tones because they don't arrive as RFC2833 but _always_ as inband or info. Ethereal is your friend... ;) There's no RFC 2833 RTP EVENT packets in eyeBeam outgoing traffic. And sorry, you can't state the contrary. ;)
AlexB
 
Posts: 55
Joined: Wed Jan 12, 2005 9:33 am

Postby AlexB » Wed Nov 16, 2005 2:12 pm

I must partially correct myself. eyeBeam does not send RFC 2833 tones if the other end-point is chan_mISDN (maybe Asterisk ZAP channel too, but haven't tried yet), while it works correctly with e.g. Asterisk mailboxes. I don't know why it shows a different behaviour and SJphone doesn't...
AlexB
 
Posts: 55
Joined: Wed Jan 12, 2005 9:33 am

Postby wamatt » Wed Nov 16, 2005 10:20 pm

AlexB wrote:
Skibum wrote:There is no DTMF issue.

Check your codec used, as well as your provider.


I use Asterisk w/ chan_mISDN and have to send DTMF as RFC 2833 to pass them over the ISDN. The driver can translate only RFC 2833 tones into inband tones. This is the only configuration that can work and that we have always used here with SJphone.
Then we bought eyeBeam and installed it without making any change in the configuration. Tones can't be translated to inband tones because they don't arrive as RFC2833 but _always_ as inband or info. Ethereal is your friend... ;) There's no RFC 2833 RTP EVENT packets in eyeBeam outgoing traffic. And sorry, you can't state the contrary. ;)


There is no DTMF issue.

Check your codec used, as well as your provider.
wamatt
 
Posts: 15
Joined: Mon Nov 07, 2005 10:33 am

Postby wamatt » Wed Nov 16, 2005 10:20 pm

AlexB wrote:I must partially correct myself. eyeBeam does not send RFC 2833 tones if the other end-point is chan_mISDN (maybe Asterisk ZAP channel too, but haven't tried yet), while it works correctly with e.g. Asterisk mailboxes. I don't know why it shows a different behaviour and SJphone doesn't...


There is no DTMF issue.

Check your codec used, as well as your provider.
wamatt
 
Posts: 15
Joined: Mon Nov 07, 2005 10:33 am

Postby wamatt » Wed Nov 16, 2005 10:24 pm

Ok seriously though I paid for the product and deserve better support than just "there is no issue".

There very clearly IS an issue. Being terse and unhelpful doesnt do much for your customer relations skibum.

It works with every other sip phone but not Eyebeam..
wamatt
 
Posts: 15
Joined: Mon Nov 07, 2005 10:33 am

Postby Derek Jacobs » Thu Nov 17, 2005 3:43 am

I checked an ethereal trace, and indeed the RFC 2833 information is there.
I checked with the programmers, and they told me that there was no issue. I'm sorry you took my reply as "terse".
Derek Jacobs
Site Admin
 
Posts: 16898
Joined: Fri Mar 07, 2003 7:33 am
Location: Canton, Connecticut

Postby AlexB » Thu Nov 17, 2005 4:25 pm

Hi skibum, what about if I send you my Ethereal traces for calls to the same destination to compare how SJphone and eyeBeam handle DTMF tones? Maybe it won't be a bug in eyeBeam, but I think you should anyway have a deeper look at this issue because it's a matter of fact that eyeBeam and X-Lite do not send or send incorrectly DTMF tones under some circumstances.

Thanks.
AlexB
 
Posts: 55
Joined: Wed Jan 12, 2005 9:33 am

Postby Derek Jacobs » Thu Nov 17, 2005 4:29 pm

Please send to my e-mail

support at counterpath dot com


Thanks
Derek Jacobs
Site Admin
 
Posts: 16898
Joined: Fri Mar 07, 2003 7:33 am
Location: Canton, Connecticut

Postby AlexB » Thu Nov 17, 2005 4:51 pm

Just sent. Thanks!
AlexB
 
Posts: 55
Joined: Wed Jan 12, 2005 9:33 am

Postby AlexB » Fri Nov 18, 2005 5:28 am

Hi Skibum, have you already had a look at the traces I sent you?
AlexB
 
Posts: 55
Joined: Wed Jan 12, 2005 9:33 am

Postby Derek Jacobs » Fri Nov 18, 2005 5:33 am

Hi Alex.. that is a job for the guys upstairs. I forwarded your e-mail.

I just tested again here, going through my asterisk box to my trunk, and it works fine.
Derek Jacobs
Site Admin
 
Posts: 16898
Joined: Fri Mar 07, 2003 7:33 am
Location: Canton, Connecticut

Postby AlexB » Fri Nov 18, 2005 6:59 am

OK, let me know if there's any news then, please.
AlexB
 
Posts: 55
Joined: Wed Jan 12, 2005 9:33 am

Next

Return to eyeBeam Support Forum

Who is online

Users browsing this forum: Google [Bot] and 9 guests