X-Lite, Asterisk, and RFC2833 DTMF Support

This forum is for eyeBeam questions and support.

Moderator: Derek Jacobs

X-Lite, Asterisk, and RFC2833 DTMF Support

Postby DirtyPete » Fri Jul 25, 2003 7:43 am

Hello,

Through discussion on the Asterisk developers mailing list, it appears that we may have stumbled upon a bug in the implementation of RFC2833 in X-Lite. Please use the following as reference:

The post on the mailing list: http://lists.digium.com/pipermail/asterisk-dev/2003-July/001176.html

It has something to do with the "duration" field in the RTP packet when sending an RFC2833 compliant DTMF sequence.

Thanks!
DirtyPete
 
Posts: 4
Joined: Fri Jul 25, 2003 7:36 am

Re: X-Lite, Asterisk, and RFC2833 DTMF Support

Postby DirtyPete » Fri Jul 25, 2003 9:32 am

DirtyPete wrote:Hello,

Through discussion on the Asterisk developers mailing list, it appears that we may have stumbled upon a bug in the implementation of RFC2833 in X-Lite. Please use the following as reference:

The post on the mailing list: http://lists.digium.com/pipermail/asterisk-dev/2003-July/001176.html

It has something to do with the "duration" field in the RTP packet when sending an RFC2833 compliant DTMF sequence.

Thanks!


A bit of added data from the mailing list:

<Direct quote from Chris Heiser of asterisk-dev>
Here's the payloads as X-Lite sends them:

010A00A0
010A00A0
010A00A0
010A00A0
010A00A0
010A00A0

As you can see... the duration field is staying at 0A0 which is incorrect.
The proper sequence should look something like this:

010A00A0
010A0140
010A01E0
010A0280
010A0320
010A03C0
etc...
</quote>
DirtyPete
 
Posts: 4
Joined: Fri Jul 25, 2003 7:36 am

Is there anyway to disable 2833 and just run DTMF inband

Postby lgoodman » Mon Jul 28, 2003 11:59 am

I think I am running into this 2833 bug as well. Is there anyway in Xlite
to disable 2833 support and just run the dtmf inband?

Thanks

Lee Goodman
lgoodman
 
Posts: 1
Joined: Mon Jul 28, 2003 11:07 am

Re: Is there anyway to disable 2833 and just run DTMF inband

Postby DirtyPete » Mon Jul 28, 2003 3:00 pm

lgoodman wrote:I think I am running into this 2833 bug as well. Is there anyway in Xlite
to disable 2833 support and just run the dtmf inband?

Thanks

Lee Goodman


Erik said he was going to fix it soon.. Hopefully soon will be within the next couple days :)

Pete
DirtyPete
 
Posts: 4
Joined: Fri Jul 25, 2003 7:36 am

Postby rob » Sun Aug 24, 2003 8:57 pm

Should be fixed in private build 1059 or greater. There was an asterisk bug as well, not sure which build you need for it.

-Rob
rob
 
Posts: 738
Joined: Wed Mar 05, 2003 8:07 am


Return to eyeBeam Support Forum

Who is online

Users browsing this forum: No registered users and 4 guests

cron